為編程愛好者分享易語言教程源碼的資源網
易語言源碼視頻(易學院) 易語言大漠腳本交流群 B全站文字廣告,誠邀與您合作 易語言實地培訓火熱招生 三葉資源網官方③群:33301895
每日必買商品 A全站文字廣告,誠邀與您合作 C全站文字廣告,誠邀與您合作 樂易論壇 三葉資源網官方③群:33301895

網站首頁 易語言相關 網絡相關源碼 正文

Galanz批量注冊登錄源碼

三葉資源網 2019-06-18 網絡相關源碼 83 ℃ 0 評論

Galanz批量注冊登錄源碼

@2335152321

.版本 2
.支持庫 iext
.支持庫 spec

.程序集 窗口程序集_啟動窗口
.程序集變量 人, 整數型
.程序集變量 次, 整數型
.程序集變量 B, 整數型
.程序集變量 t, 整數型

.子程序 __啟動窗口_創建完畢

編輯框3.內容 = “60”
編輯框4.內容 = “120”

.子程序 _按鈕1_被單擊

key = 編輯框2.內容
透明標簽12.標題 = “正在嘗試注冊登錄”
線程_啟動 (&開始)

.子程序 開始

.如果真 (到整數 (人數.內容) = 0 且 到整數 (次數.內容) = 0)
    獲取手機號 ()
    返回 ()
.如果真結束
.如果真 (到整數 (人數.內容) ≠ 0 且 到整數 (次數.內容) = 0)
    .判斷開始 (人 = 到整數 (人數.內容))
        信息框 (“操作完成,執行次數:” + 到文本 (次), 0, , )
    .默認
        獲取手機號 ()
    .判斷結束

.如果真結束
.如果真 (到整數 (人數.內容) = 0 且 到整數 (次數.內容) ≠ 0)
    .判斷開始 (次 = 到整數 (次數.內容))
        信息框 (“操作完成,執行次數:” + 到文本 (次), 0, , )
    .默認
        獲取手機號 ()
    .判斷結束

.如果真結束


.子程序 獲取手機號
.局部變量 待解析, 文本型

次 = 次 + 1
透明標簽8.標題 = 到文本 (次) + “次”
待解析 = 到文本 (網頁_訪問_對象 (“http://47.97.118.96:9180/service.asmx/GetHM2Str?token=” + key + “&xmid=173946&sl=1&lx=0&a1=&a2=&pk=&ks=0&rj=0 ”))
調試輸出 (待解析)
號碼 = 文本_取右邊 (待解析, “hm=”)
.判斷開始 (號碼 = “”)
    .如果真 (待解析 = “-8”)
        釋放號碼 ()
    .如果真結束
    返回 ()
.默認
    引索 = 超級列表框1.插入表項 (-1, 號碼, , , , )
    .判斷開始 (登錄 (號碼))
        獲取驗證碼 ()
    .默認
        超級列表框1.置標題 (引索, 2, “該用戶已存在”)
        釋放號碼 ()
        獲取手機號 ()
    .判斷結束

.判斷結束


.子程序 釋放號碼

網頁_訪問_對象 (“http://47.96.183.58:9180/service.asmx/sfHmStr?token=” + key + “&hm=” + 號碼)

.子程序 獲取驗證碼

網頁_訪問_對象 (“https://api.galanz.com/prod/app/sms/sendMsg”, 1, “mobile=” + 號碼 + “&msgType=sms_moblie_register”)
獲取短信 ()

.子程序 獲取短信
.局部變量 待解析, 文本型
.局部變量 i, 整數型

待解析 = 到文本 (網頁_訪問_對象 (“http://47.97.118.96:9180/service.asmx/GetYzm2Str?token=” + key + “&hm=” + 號碼 + “&xmid=173946&sf=1”))
.判斷循環首 (待解析 = “1”)
    待解析 = 編碼_Utf8到Ansi (網頁_訪問_對象 (“http://47.97.118.96:9180/service.asmx/GetYzm2Str?token=” + key + “&hm=” + 號碼 + “&xmid=173946&sf=1”))
    超級列表框1.置標題 (引索, 1, “第” + 到文本 (i) + “次獲取驗證碼”)
    驗證碼 = 文本_取出中間文本 (待解析, “驗證碼”, “,”)
    i = i + 1
    延遲 (1000)
    .如果真 (驗證碼 = “-1”)
        獲取手機號 ()
        返回 ()
    .如果真結束
    .如果真 (i = 15)
        超級列表框1.置標題 (引索, 1, “獲取超時”)
        獲取手機號 ()
        返回 ()
    .如果真結束
    調試輸出 (待解析)
.判斷循環尾 ()
超級列表框1.置標題 (引索, 1, 驗證碼)
注冊 ()

.子程序 注冊, 邏輯型
.局部變量 post, 文本型
.局部變量 待解析, 文本型

post = “mobile=” + 號碼 + “&password=a12345&code=” + 驗證碼 + “&invitationCode=” + 編輯框1.內容
待解析 = 編碼_Utf8到Ansi (網頁_訪問_對象 (“https://api.galanz.com/prod/app/appRegister”, 1, post))
調試輸出 (待解析)
.如果真 (尋找文本 (待解析, “該用戶已存在”, , 假) ≠ -1)
    超級列表框1.置標題 (引索, 2, “該用戶已存在”)
    獲取手機號 ()
    返回 (假)
.如果真結束
.如果真 (尋找文本 (待解析, “操作成功”, , 假) ≠ -1)
    超級列表框1.置標題 (引索, 2, “注冊成功”)
    登錄 (號碼)
    返回 (真)
.如果真結束
.如果真 (驗證碼 = “”)
    超級列表框1.置標題 (引索, 2, “驗證碼錯誤”)
    獲取手機號 ()
    返回 (假)
.如果真結束

.判斷開始 (t > 10)
    超級列表框1.置標題 (引索, 2, “注冊失敗”)
    t = 0
    B = B + 1
    透明標簽2.標題 = “注冊失敗:” + 到文本 (B) + “次”
    獲取手機號 ()
.默認
    t = t + 1
    超級列表框1.置標題 (引索, 2, “第:” + 到文本 (t) + “次注冊”)
    延遲 (1000)
    注冊 ()
.判斷結束
返回 (假)

.子程序 登錄, 邏輯型
.參數 手機號, 文本型
.局部變量 待解析, 文本型
.局部變量 post, 文本型
.局部變量 結果, 邏輯型
.局部變量 i, 整數型

post = “password=a12345&username=” + 手機號
待解析 = 編碼_Utf8到Ansi (網頁_訪問_對象 (“https://api.galanz.com/prod/app/app_login”, 1, post))
.判斷開始 (尋找文本 (待解析, “用戶名不存在”, , 假) ≠ -1)
    結果 = 真
.默認
    結果 = 假
    .如果真 (尋找文本 (待解析, “處理成功”, , 假) ≠ -1)
        超級列表框1.置標題 (引索, 3, “登錄成功”)
        人 = 人 + 1
        透明標簽9.標題 = 到文本 (人) + “人”
        置隨機數種子 ()
        i = 取隨機數 (到整數 (編輯框3.內容), 到整數 (編輯框4.內容))
        .判斷循環首 (i ≠ 0)
            透明標簽12.標題 = “休息” + 到文本 (i) + “秒后繼續”
            i = i - 1
            延遲 (1000)
        .判斷循環尾 ()
        透明標簽12.標題 = “正在嘗試注冊”
        開始 ()
    .如果真結束

.判斷結束
調試輸出 (待解析)
返回 (結果)
文件下載

Tags:Galanz批量注冊

來源:三葉資源網,歡迎分享,公眾號:iisanye,(三葉資源網官方③群:33301895

本文暫時沒有評論,來添加一個吧(●'?'●)

歡迎 發表評論:

百度站內搜索
關注微信公眾號
三葉資源網官方③群:三葉資源網官方③群

網站分類
隨機tag
Sqlite本地庫喊麥進銷存系統騰訊滑塊驗證碼模塊源碼淘寶時間同步文件拖拽群控模擬器工控之交通燈硬筆四方枚舉IE插件HttpWatch破解版網頁POSTbitlocker加密文本處理車牌識別界面UIAI文字轉語音超級代理服務端安全CALL
最新評論
快速时时彩开奖记录